Back to overview
Maintenance
Server Update
May 2, 2026 at 2:38am UTC
–
May 2, 2026 at 2:42am UTC
Affected services
Bubblehost
Client Area
Server 2
Resolved
May 2, 2026 at 2:42am UTC
Maintenance ended
Affected services
Created
May 2, 2026 at 2:38am UTC
Bubblehost has introduced an emergency server update provided by cPanel.
This update will increase performance and enhance security mechanisms.
Affected services